Меню
Главная
Авторизация/Регистрация
 
Главная arrow Информатика arrow MS Excel: виконання обчислень в таблицях

Використання логічних функцій та операцій для опрацювання даних. Засоби статистичного аналізу даних

Логічні функції дають змогу розв'язувати за допомогою ЕТ логічні задачі. Логічні функції дають змогу виконувати логічні операції над умовами. Умова -- це вираз, що містить величину та інші вирази одного і того ж типу (числові, символьні, логічні), зв'язані між собою одним із знаків відношень: =, о , >, <, >=, <=. Такі умови називаються простими, вони можуть складатися із даних, посилань, виразів. Будь-яка умова може набувати одного з двох можливих логічних значень: «істинно» або «хибно».

Для перевірки умови використовується функція ЕСЛИ, яка має такий формат:

=ЕСЛИ(умова; виразі ;вираз2).

Дія такої функції полягає в наступному: табличний процесор перевіряє істинність записаної в ній логічної умови і заносить до тієї комірки, в якій знаходиться ця функція, значення Виразі, якщо умова істинна, або значення Вираз2, якщо умова хибна.

Приклад.

= ЕСЛИ(А1>А2;Ю0;0)

=ЕСЛИ(А11>В12;"Успішність учня А краща";"Успішність учня В краща або така ж")

Часто в задачах використовуються складені умови, і

Складеною умовою називається кілька простих умов, які з'єднані логічними «І/АБО/НЕ»: І (логічне множення;. АБО (логічне додавання), НЕ (логічне заперечення).

Результатом логічної операції І буде «істинно» тоді і тільки тоді, коли істинні всі її складові умови.

Результатом логічної операції АБО буде «істинно», якщо істинна хоча б одна умова.

Для виконання вказаних логічних операцій в ЕТ існують логічні функції И, ИЛИ, НЕ аргументами яких є умови.

Приклад:

=ЕСЛИ(И(А6>4;Р1>4);"Ви успішно склали іспити та зараховані до вузу";"Ви не пройшли конкурсу")

Вправа

У комірках запропонованої таблиці, які позначені символом * - ввести правдоподібні вхідні дані, а в тих, що позначені символом ? - ввести відповідні функції для здійснення розрахунків.

Після введення вхідних даних та відповідних формул початкова таблиця мала б набути вигляду, подібного до такого, як на наступному малюнку.

Розв'язок:

  • 1) E2 <--- =IF(C2>D2;C2-D2;"")
  • 2) F2 <--- =IF(C2
  • 3) Копіюю E2:F2 на E3:F5
  • 4) C6 <--- =SUM(C2:C5)
  • 5) Копіюю С6 на D6:F6

До складу Microsoft Excel входить пакет аналізу, призначений для вирішення складних статистичних і інженерних завдань. Засоби, які включені в пакет аналізу даних, доступні через команду Аналіз даних у меню Сервіс. Якщо цієї команди немає в меню, необхідно завантажити надбудову Пакет аналізу.

Засоби аналізу даних дозволяють виконувати декілька видів дисперсійного аналізу, кореляційний і ковариационный аналіз, створювати одновимірний статистичний звіт, що містить інформацію про центральну тенденцію і мінливість вхідних даних, виробляти вибірку з генеральної сукупності і так далі

Статистичні функції

Статистичні функції використовуються для аналізу діапазонів даних, обчислення параметрів, що характеризують випадкові величини, представлених безліччю чисел, або їх розподілів, наприклад, стандартного відхилення, середнього значення, і тому подібне Зокрема, ми можемо знайти рівняння прямої або експоненціальної кривої, що оптимально узгоджується з дослідними даними. Приклад використання статистичної функції розглянутий нижче у вправі 3.

Вправа

Фірма бажає придбати будівлю під офіс і має оцінити вартість нерухомості, запропонованої на ринку.

Розв'язання:

Можна використати множинний регресійний аналіз для прогнозування вартості будівлі. Передбачається, що використовується функція У = F(xi), де Y-- вартість будівлі, хі -- площа, х2 -- кількість поверхів, хЗ -- кількість входів, х4 -- строк експлуатації будівлі.

Для прогнозування вартості триповерхової будівлі, що експлуатується ЗО років, з площею у 2000 м" та 2 входами, використовують Прайс-лист для нерухомості подібного типу у вигляді таблиці:

Для оцінки вартості використовується функція =ЛИНЕЙН (ві-доміУ;відомь?), або функція

=ЛГФПРИБЛ(в ідом і Y; відомії).

Кожна з функцій не визначає Y у відповідному рівнянні множинної регресії, а визначає значення коефіцієнтів а, та Ь, починаючи з старшого коефіцієнта ап. Обчислені коефіцієнти використовуються у формулі, яка реалізує рівняння множинної регресії (лінійної, якщо використовувалась функція ЛИНЕЙ, і нелінійної, якщо використовувалась функція ЛГФПРИБЛ).

Відомими Ye значення, розташовані у комірках ЕЗ:Е13, відомими Хе значення, розташовані у комірках A2:D13.

Для визначення коефіцієнтів треба створити заголовки у комірках А15:Е15 і занести вибрану статистичну функцію у комірки А16:Е16 як формулу масиву:

у комірку Е20 заноситься формула яка реалізує рівняння множинної лінійної регресії =D16*A20+C16*B20+B16*C20+A16*D20+E16, і отримується результат.

Функції для роботи з датами і часом

Для роботи з датами і часом використовується більше десятка функцій. Виберіть команду Функція (Function) у меню Вставка (Insert). У діалоговому вікні Майстер функцій -- крок 1 з 2 (Insert Function) (мал. 16.6) у списку або категорію (Function category) виділите Дата і час (Date&Time).

Приклад використання функції Дата і час (Date&Time) розглянутий нижче (див. Вправи).

Текстові

Функція Текстові (Text) перетворить числове значення у форматований текст, і результат більше не бере участь в обчисленнях як число. Амперсанд (&) використовується для об'єднання декількох текстових рядків в один рядок.

Наприклад, у вічку ВЗ ви можете записати прізвище продавця (Петров), у вічку СЗ -- об'єм його продажів (5000). Після запису в якому-небудь вічку Вз& «продал»&ТЕКСТ(СЗ; «0,00 крб.»)&" одиниць товару» при проведенні обчислень станеться об'єднання вмісту вічок в одну фразу: Петров продав на 5000,00 крб. одиниць товару.

 
Если Вы заметили ошибку в тексте выделите слово и нажмите Shift + Enter
< Предыдущая   СОДЕРЖАНИЕ   Следующая >
 
СКАЧАТЬ ОРИГИНАЛ
MS Excel: виконання обчислень в таблицях